Install bitcoin-qt in Debian Jessie Bitcoin-qt debian jessie

Содержание статьи

Okay, I’ll start with the command-lines.  To deliver the first couple, you have to be root (or say ‘sudo’ at the beginning of the line if your system is set up that way)

echo ‘deb-src sid main contrib non-free’ >> /etc/apt/sources.list

If you don’t have your browser open wide enough, that line may wrap, but you’re supposed to enter it all on one line before you hit return. This gets you access to the source code for packages for ‘sid’ which is the unstable version of debian.  That’s where the source code for the bitcoin clients live, for now at least.  This is as of December 2014, and may have changed by the time you read this.  Sid also has a binary, but you can’t use the sid binary with a jessie libc and kernel.  The good news is that sid has sources for this package that build just fine on jessie using jessie’s libc and interacting with jessie’s kernel.

Now, still as root (or with another sudo), type

apt-get update

This will let apt know about all the sid sources, which will be big news as far as it’s concerned.  Now go to the directory where you want all the files installed.  here is how I do it:

cd /home


you should see your user home directory – a directory that has your username.  cd into it, then do

mkdir ./src

cd src

apt-get source bitcoin

The system will download a few archives and unpack a bunch of files.  Next do

apt-get build-dep bitcoin

apt-get –install-recommends install libbitcoin-dev

This will load all the packages from jessie that have to be installed on your system before bitcoin will build.  Strictly speaking, the second line is optional.  I’m including it because it’s a lot of related stuff that may not continue to be optional as the source code for bitcoind evolves.  Now, here is the last command (for now) that you have to issue as root.  Assuming your username is ‘lyle’ you’d type

chown -R lyle:lyle *bitcoin*

This is optional, and will make for more typing later, but I don’t like to build things as root.  Too much can go wrong.  So this command is to make your non-root account own all those files.  Obviously, if your username is ‘katherine’ you have a bit more typing to do to enter the equivalent line.  You are done being root for now, so save yourself some stress and exit the root session (or stop typing ‘sudo’ before all these commands). Next, as your regular account,

cd ~/src/bitcoin-0.9.3

Again, this is as of December 2014, and the version number may have changed by the time you read this. (Edit as of March 2015: the version number is now 0.10.0.) Now you are ready to start building.  Type


and wait a minute; the autoconfiguration stuff will figure out a whole bunch of things about your computer and environment and what is available to compile with, link to, and etc. It’ll print a bunch of messages, but if you have all the dependencies (in some version it understands) it shouldn’t hit an error. Next, type

./configure –with-incompatible-bdb

Bitcoin’s standard client uses a database format that no longer exists anywhere else; the version of the database you got when you installed your dependencies is much newer than the one the original client used.  So you’ll see a warning fly by about ‘wallets opened with this build will not be compatible.’

This is normal, at least for building on jessie.  What it means is you’ll be able to open any standard wallet, but when you do, the current version of the database software will change its format.  After that, the standard bitcoin client won’t understand that wallet anymore.

If this is unacceptable, then you have a much tougher build process ahead of you, because it is damnably hard to force  version downgrades to a version of the database that ancient on Debian Jessie without breaking all kinds of dependencies and packages that you care about a lot.  Anyway, I’m not covering that messy process.  Just be aware that the client you’re building isn’t standard.

This won’t affect your ability to spend your coins, receive coins, do transactions, etc.  If you ever need your coins in a standard wallet, you can get anything that uses a standard wallet, give it the keys from the wallet this client uses, then tell it to rescan, and it’ll find your coins and you’ll have them in a standard wallet.  Anyway, the above command tells your computer that you know about the database thing and are going ahead anyway.

The next command you enter is


This will kick off a build process that could take up to an hour, if your computer is an OLPC or an ARM or has less than a gigabyte or two of RAM.   If you have a nice desktop computer though, it ought to build in about six minutes.  When it’s done, enter the commands

cd src

ls *bitcoin*

If the two files bitcoind and bitcoin-cli are listed, that’s good.  There’ll be some other files listed here, but those are the important ones that you just built.  They are the daemon and the command-line client, respectively.  Now enter the two commands

cd qt

ls bitcoin-qt

If the computer lists the file ‘bitcoin-qt’, you’re golden.  That’s the graphical client. Enter the command

cd ~/src/bitcoin-0.9.3/src

Now you have to be root again.  Sorry, I know it’s stressful.  But we’re on the last leg of this thing now; we’re just going to copy some files to the places they ought to be on your system and make root own just those files.  As root, enter

chown root:root bitcoind

chown root:root bitcoin-cli

mv bitcoind /usr/bin/

mv bitcoin-cli /usr/bin/

cd qt

chown root:root bitcoin-qt

mv bitcoin-qt /usr/bin/

cd ../../share/pixmaps/

cp bitcoin*.xpm /usr/share/pixmaps/

chown root:root /usr/share/pixmaps/bitcoin*

cd ../../debian

cp bitcoin-qt.desktop /usr/share/applications/

chown root:root /usr/share/applications/bitcoin-qt.desktop

cd ../contrib/debian/manpages/

cp bitcoin*.1 /usr/share/man/man1/

chown root:root /usr/share/man/man1 bitcoin*

cp bitcoin*.5 /usr/share/man/man5/

chown root:root /usr/share/man/man5/bitcoin*

And at this point you are done.  You can stop being root now.  The bitcoin client is installed on your system.  And it was only about a thousand percent more annoying than just typing “sudo apt-get install bitcoin”. But if you really want annoying, start it up and watch it begin a 20-gigabyte blockchain download. Again, that’s as of December 2014, and it’ll be bigger by the time you read this.

Это интересно:

Bits from Debian - Debian 8.0 Jessie has been released!

New Step by Step Roadmap for Winklevoss Bitcoin The effect on Bitcoin price will be quite amazing. The Winkdex is […]

Cme Bitcoin Fundamentals Explained You can discover the present exchange rate at It is going to also open up […]

There’s money to be made, but there’s a bubble too. Better yet, when the bubble does burst, each of the […]

Bitcoin Bubble – the Conspiracy The huge question is whether that is indicative of a bubble because a growth in […]

Cme Bitcoin – the Conspiracy CME, for instance, is using the Bitcoin Reference Rate that is an aggregate of prices […]

The Downside Risk of Bitcoin Bubble There’s money to be made, but there’s a bubble too. It has quite real […]

What You Should Do to Find Out About Winklevoss Bitcoin Before You’re Left Behind It is very hard to conduct […]

bitcoin bankomatai lietuvoje.

Дистрибутив Debian скачать. Пингвинус Linux

For bitcoin-core; For bitcoin-qt (graphical interface). Installing Berkeley DB 4.8. 1. Change the sources.list to use squeeze repositories; 2.Now you can install Berkeley DB version 4.8 (libdb4.8). Downloading and Compiling Bitcoin Core. Configure the system for compilation; Compile. Installing and Running Bitcoin Core ...

Limit to suite: [wheezy] [wheezy-updates] [wheezy-backports] [wheezy-backports- sloppy] [jessie] [jessie-updates] [jessie-backports] [jessie-backports-sloppy] [ stretch] ... Package bitcoin-qt. sid (unstable) (utils): peer-to-peer network based digital currency - GUI 0.15.1~dfsg-1: alpha amd64 arm64 armel armhf hppa i386 m68k ...

Apr 30, 2013 ... Ensure Vidalia is running; Download Bitcoin-QT, and extract; On your Debian command line, run sudo apt-get install libqtgui4; Go to the bin folder in the extracted Bitcoin, choose the 32 or 64 forlder depending on your system (32-bit/ 64-bit), double click the bitcoin-qt , select "Run"; Go to "Settings" in the ...

Package bitcoin-qt. sid (unstable) (utils): peer-to-peer network based digital currency - GUI 0.15.1~dfsg-1: alpha amd64 arm64 armel armhf hppa i386 m68k mips ... sid (unstable) (debug): debug symbols for bitcoin-qt ... jessie (oldstable) ( libdevel): Bitcoin toolkit library for asynchronous apps - development headers 2.0 -2.2: ...

Jul 25, 2016 ... The repository is for ubuntu and you're on debian. So it doesn't have packages for jessie. Use this instead: Hope this helps! :) ...

Jan 9, 2014 ... Here is what I did on Debian Wheezy. Create /etc/apt/sources.list.d/bitcoin.list with content. deb-src precise main . Import this repository PGP public key with. apt-key adv --keyserver hkp://subkeys --recv-keys D46F45428842CE5E. Create (temporarily) ...

Jun 9, 2017 ... Objective. The objective is to install latest Bitcoin-node binaries on Debian 9 Stretch Linux. Operating System and Software Versions. Operating System: - Debian 9 Stretch; Software: - Bitcoin 0.14.1. Requirements. Privileged access to your Debian system will be required. Difficulty. EASY. Conventions.

Dependencies for the GUI: Ubuntu & Debian. If you want to build Bitcoin-Qt, make sure that the required packages for Qt development are installed. Either Qt 5 or Qt 4 are necessary to build the GUI. If both Qt 4 and Qt 5 are installed, Qt 5 will be used. Pass --with-gui=qt4 to configure to choose Qt4. To build without GUI pass ...

To install both the GUI and the daemon, type the following line and read both the GUI instructions and the daemon instructions. Note that you can't run both the GUI and the daemon at the same time using the same configuration directory. sudo apt-get install bitcoin-qt bitcoind. After choosing what packages to install, you will ...

Mar 5, 2014 ... In the case of bitcoin-qt it's not as we need to link against the system's Qt. This means that we need to share the libc++/glibc implementation. .... It's one thing to pull some packages from testing [currently named jessie which will be the release that replaces stable/wheezy one day], but it is another to pull such ... news bitcoin qt debian jessie bitcoinwisdom difficulty chart.

Debian Linux -

Quickly build and launch digital campaigns with Azure Free Trial.

Do you want to use Bitcoin on Linux? This tutorial explains how to install and use Bitcoin Core on Debian Linux. Bitcoin Core is the official Bitcoin Wallet from I will use the latest version from the GIT repository at

In order to compile and run, Bitcoin Core depends on some other tools which must be installed prior to compiling :

sudo apt-get install build-essential autoconf libssl-dev libboost-dev libboost-chrono-dev libboost-filesystem-dev libboost-program-options-dev libboost-system-dev libboost-test-dev libboost-thread-dev

For bitcoin-qt (graphical interface)

If you want the graphical frontend, also install the following dependencies. If you just want bitcoind, you can skip this step.

sudo apt-get install libqt4-dev libprotobuf-dev protobuf-compiler libqrencode-dev

Installing Berkeley DB 4.8

Compiling Bitcoin Core requires the Berkeley DB version 4.8 which is not available in the wheezy repositories, so we must use squeeze repositories. Note that if you don't need a wallet (i.e. if you want to run a headless Bitcoin node and keep your wallet elsewhere) you can completely skip this section and jump directly to downloading and compiling Bitcoin Core.

1.Change the sources.list to use squeeze repositories

Edit /etc/apt/sources.list :

vi /etc/apt/sources.list

Add the following lines in the head of file :

deb http://[your favorite repository]/debian/ squeeze main contrib non-free deb-src http://[your favorite repository]/debian/ squeeze main contrib non-free 

2.Now you can install Berkeley DB version 4.8 (libdb4.8)

apt-get install libdb4.8++-dev libdb4.8-dev

Downloading and Compiling Bitcoin Core

Go to the branches list on the Bitcoin Core project site (, locate the latest version number, and substitute "0.11" in the command below with that.

cd /root git clone -b 0.11 cd bitcoin/

Configure the system for compilation


if you dont need bitcon GUI, use this command :

./configure --without-gui

else use this :


Note: If you skipped the Berkeley DB 4.8 dependency above because you don't need a wallet, you must add "--disable-wallet" (without the quotation marks) to the end of the line that starts with ./configure above.



Installing and Running Bitcoin Core

make install

After that, you will be able to run Bitcoin Core by typing:

bitcoind (the text based backend)

bitcoin-qt (the graphical frontend)

bitcoin-cli (the command-line client)


Some useful command lines :

To start bitcoin server as daemon :

bitcoind -daemon

To get a list of accounts on the system :

bitcoin-cli listreceivedbyaddress 0 true

To associate an existing address (here : 1GBykdD628RbYPr3MUhANiWchoCcE52eW2) to an account name :

bitcoin-cli setaccount 1GBykdD628RbYPr3MUhANiWchoCcE52eW2 myfirstaccount

To send bitcoins (here : 0.15) to an address (here : 1AYJyqQHCixxxxxxffevxxxxQosCWqn1bT) :

bitcoin-cli sendfrom myfirstaccount 1AYJyqQHCixxxxxxffevxxxxQosCWqn1bT 0.15

To know if your server is up to date (synchronised) :

echo `bitcoin-cli getblockcount 2>&1`/`wget -O - 2>/dev/null`

view as pdf | print

Share this page:

freebitcoin вход на сайт на русском с официального сайта.

How to Install Proxmox on Debian Jessie -

Debian 8.10 was released December 9th, 2017. Debian 8.0 was initially released on April 26th, 2015. The release included many major changes, described in our press release and the Release Notes.

Debian 8 has been superseded by Debian 9 (stretch).

To obtain and install Debian, see the installation information page and the Installation Guide. To upgrade from an older Debian release, see the instructions in the Release Notes.

The following computer architectures are supported in this release:

Contrary to our wishes, there may be some problems that exist in the release, even though it is declared stable. We've made a list of the major known problems, and you can always report other issues to us.

Last but not least, we have a list of people who take credit for making this release happen.

промокод hashflare 400.

<< Go back to the previous page

Похожие статьи